favorite
favorite
hide
unhide
flag

Posted

print

2013 Dodge Avenger SE 2.4 (winfield)

2013 Dodge Avenger SE 2.4 1 thumbnail2013 Dodge Avenger SE 2.4 2 thumbnail2013 Dodge Avenger SE 2.4 3 thumbnail2013 Dodge Avenger SE 2.4 4 thumbnail
The odometer shows 182000. It ran extremely good when I got it. Less than 200 miles later it stopped running and since then I’ve put 2 new front calipers on it. New plugs, new belt, new throttle pedal ( TPS ) new throttle body, new transmission line because the old one had a slight drip. New intake gasket, new valve pan gasket kit, new thermostat and whole housing. . I hooked my computer to it and it says there is a correlation between the new throttle body and TPS. There was a tag under the plastic engine cover that stated there was another engine installed at some point but it did not show the miles. Like I said when it runs it runs amazing. I had also painted the front bumper as well. Now it does start and run but runs rough. Will need a battery as well. The one in it isn’t the correct size. Thank you for looking and feel free to call and leave a message or text at anytime. I did just shampoo the seats and carpets and will finish detailing the inside this week. Feel free to call or text anytime. If no answer please leave a message. show contact info . I have over 5k in this car and would like to get $1000.00 for it. Best offer just shoot me an offer thank you. I really need the money. Thanks again for looking.

post id: 7744150559

posted:

best of [?]

loading
reading
writing
saving
searching